Wednesday, 12 August 2009

Upgrade kills forum software

I've just uploaded the update files for the latest version of our forum software, and it seems to have killed the forums - how is beyond me! I've put an urgent support request in to our tech support folks, and we'll have it back up & running as soon as possible.

I've been putting off the install for just such reasons, as it invariably causes some problems, but it just goes to prove that there's no such thing as a "good time" to do the updates. Looking on the bright side, at least most of your are at work, and can get some work done for the day instead? just remember not to do too much as they might get suspicious! lol

Keep checking back through the day - I'll keep this entry updated with progress (or lack thereof).

Sorry for the inconvenience! :o(

16 comments:

  1. Mike

    AAARGH wot have you done???
    getting BM withdrawal symptoms LOL

    all the best
    Walrus :D

    ReplyDelete
  2. Noooooo can't go much longer without BM.... Guss I will have to build some more.

    Mish

    ReplyDelete
  3. You need a little linux VM with a copy of the board to allow you to test upgrades before going life.

    Peter

    ReplyDelete
  4. A Linux VM would be nice to use as a test bed, but I don't have the skills at the moment to set one up. I might have to look into it before the next update comes along, so thanks for the tip off :o)

    ReplyDelete
  5. Gah! Hope they fix it quickly, I'm having to buy kits online to keep myself entertained. And I've had to do some work!!

    Doug.

    ReplyDelete
  6. Drop me a PM when everything is back up - I should be able to help with a VM, VMWare server is free, and it may help you longer term

    ReplyDelete
  7. Ah that would explain this message then:

    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /nfs1/britmodeler.com/www/forums/admin/sources/base/ipsRegistry.php on line 30

    Ross

    ReplyDelete
  8. Give it to GregB to fix....all he needs is a RE Screwdriver!

    ReplyDelete
  9. lol might take a bit more than that this time. I've not got a flippin' clue what's gone wrong. :o(

    ReplyDelete
  10. It looks like a PHP function has been corrupted by the update - one of the source files is missing a closing brace to terminate the function.

    ReplyDelete
  11. Wonder if it's a typo in the files I downloaded then? Hmmmm....

    ReplyDelete
  12. I'd re-download the update, and check that it's the same size if you can, or download the previous version that was working, and apply that as a 'downgrade'

    Just a thought

    ReplyDelete
  13. The current download is the same as the one I downloaded earlier, but I downloaded it again in case they'd changed one character to another, but that didn't work. Still waiting for support - Most of America will be awake soon, so we should get a response shortly :o(

    ReplyDelete
  14. i go away for a few days and look what happens!! lol! i hope you get it faxed soon i need my AirFIX!

    ReplyDelete
  15. Is it working yet? Well is it? :-D
    Need my BM fix

    Mish

    ReplyDelete
  16. I'm getting loads of IPS errors again.....

    ReplyDelete